Allplan Forum Index du Forum
Allplan Forum Index du Forum FAQ Rechercher S’enregistrer Connexion

Problème de de légende
Aller à la page: 1, 2  >
 
Poster un nouveau sujet   Répondre au sujet    Allplan Forum Index du Forum -> ALLPLAN -> DIVERS
Sujet précédent :: Sujet suivant  
Auteur Message
dead
Membre

Hors ligne

Inscrit le: 20 Déc 2011
Messages: 1 631
Localisation: 2 chèvres
Masculin

MessagePosté le: Jeu 14 Sep 2017 - 16:14    Sujet du message: Problème de de légende Répondre en citant

salut tout le monde,

j'ai un souci avec une légende sur laquelle je vais péter un câble !

je souhaite faire un légende qui récupère l'attribut "Calcul" (@480) pour en tirer un montant de taxe d'aménagement, mais je ne comprends pas pourquoi ça ne fonctionne pas :

j'arrive à récupérer mon attribut mais je ne peut pas faire un calcul avec.

j'ai simplifié la légende avec une opération tout bête :

je mets un valeur de 5 à mon attribut calcul et si je le multiplie par 5 il me donne 0 !!!! Shocked Mad Mad Mad Mad Mad Mad

je vous laisse un pdf pour mieux comprendre : http://www.sendspace.com/file/c0138n


c'est pas faux !

Dernière édition par dead le Ven 27 Oct 2017 - 14:52; édité 1 fois
Revenir en haut
Publicité






MessagePosté le: Jeu 14 Sep 2017 - 16:14    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
bco
Modérateur

Hors ligne

Inscrit le: 23 Mar 2012
Messages: 4 731
Localisation: Toulouse
Masculin

MessagePosté le: Jeu 14 Sep 2017 - 16:23    Sujet du message: Problème de de légende Répondre en citant

L'attribut Calcul est de type Texte et non numérique, d'où le résultat 0...
Utilise un autre attribut comme V6, V7, V8 et V9 qui sont de type décimal...


Revenir en haut
Visiter le site web du posteur
dead
Membre

Hors ligne

Inscrit le: 20 Déc 2011
Messages: 1 631
Localisation: 2 chèvres
Masculin

MessagePosté le: Jeu 14 Sep 2017 - 16:34    Sujet du message: Problème de de légende Répondre en citant

y a t il des attributs dans les attributs projet qui sont décimaux ?


c'est pas faux !
Revenir en haut
bco
Modérateur

Hors ligne

Inscrit le: 23 Mar 2012
Messages: 4 731
Localisation: Toulouse
Masculin

MessagePosté le: Jeu 14 Sep 2017 - 16:51    Sujet du message: Problème de de légende Répondre en citant

Ceux qui par défaut affichent 0,0... Wink
Si tu as un doute, regarde dans le fichier "C:\ProgramData\Nemetschek\Allplan\2017\ETC\xml\AttributeDefinitionCollectionAllplan_fr.xml".
Les attributs de type Décimal sont ceux dont la balise DataType est "R".


Revenir en haut
Visiter le site web du posteur
dead
Membre

Hors ligne

Inscrit le: 20 Déc 2011
Messages: 1 631
Localisation: 2 chèvres
Masculin

MessagePosté le: Jeu 14 Sep 2017 - 17:10    Sujet du message: Problème de de légende Répondre en citant

on peut pas changer ces balises ?


c'est pas faux !
Revenir en haut
bco
Modérateur

Hors ligne

Inscrit le: 23 Mar 2012
Messages: 4 731
Localisation: Toulouse
Masculin

MessagePosté le: Jeu 14 Sep 2017 - 18:13    Sujet du message: Problème de de légende Répondre en citant

Et non !


Revenir en haut
Visiter le site web du posteur
dead
Membre

Hors ligne

Inscrit le: 20 Déc 2011
Messages: 1 631
Localisation: 2 chèvres
Masculin

MessagePosté le: Ven 15 Sep 2017 - 08:04    Sujet du message: Problème de de légende Répondre en citant




c'est pas faux !
Revenir en haut
olivier1
Administrateur

Hors ligne

Inscrit le: 17 Mar 2012
Messages: 4 598
Localisation: NIORT
Masculin

MessagePosté le: Ven 15 Sep 2017 - 11:27    Sujet du message: Problème de de légende Répondre en citant

je sais ça fait ça souvent avec Allplan




Les tâches urgentes: [Done]
Les tâches impossibles: [On Time]
Les miracles: [Delayed] - Merci d'attendre 24h
Revenir en haut
dead
Membre

Hors ligne

Inscrit le: 20 Déc 2011
Messages: 1 631
Localisation: 2 chèvres
Masculin

MessagePosté le: Ven 15 Sep 2017 - 11:38    Sujet du message: Problème de de légende Répondre en citant

moi aussi si ça peut rassurer


c'est pas faux !
Revenir en haut
dead
Membre

Hors ligne

Inscrit le: 20 Déc 2011
Messages: 1 631
Localisation: 2 chèvres
Masculin

MessagePosté le: Ven 27 Oct 2017 - 16:24    Sujet du message: Problème de de légende Répondre en citant

bco a écrit:
Et non !


pourquoi ?


c'est pas faux !
Revenir en haut
bco
Modérateur

Hors ligne

Inscrit le: 23 Mar 2012
Messages: 4 731
Localisation: Toulouse
Masculin

MessagePosté le: Ven 27 Oct 2017 - 16:46    Sujet du message: Problème de de légende Répondre en citant

Parce que c'est comme cela que ça a été défini. Mr. Green

Comme je te l'ai dit dès ma première réponse, utilise un des attributs V6, V7, V8, V9 ou tout autre attribut défini pour recevoir une valeur décimale.
L'attribut "Calcul" permet de stocker l'ensemble de la formule de calcul, donc c'est une chaine de caractères.


Revenir en haut
Visiter le site web du posteur
PHILC
Modérateur

Hors ligne

Inscrit le: 12 Déc 2011
Messages: 6 465
Localisation: 46.14'38,77N - 5.58'59,61E
Masculin

MessagePosté le: Ven 27 Oct 2017 - 17:00    Sujet du message: Problème de de légende Répondre en citant

et pourquoi appel t'on un âne... un âne ..parce que Dieu l'a définit comme ça ... Mr. Green Very Happy


« Deux hommes intelligents, d'idées opposées, trouveront beaucoup plus de choses à se dire que deux cons appartenant à un même parti. »
Revenir en haut
Visiter le site web du posteur
dead
Membre

Hors ligne

Inscrit le: 20 Déc 2011
Messages: 1 631
Localisation: 2 chèvres
Masculin

MessagePosté le: Ven 27 Oct 2017 - 17:48    Sujet du message: Problème de de légende Répondre en citant

ok mais dans mon cas je vois pas comment exploiter ces attributs, il ma faudrait un attribut "projet" numérique.


c'est pas faux !
Revenir en haut
bco
Modérateur

Hors ligne

Inscrit le: 23 Mar 2012
Messages: 4 731
Localisation: Toulouse
Masculin

MessagePosté le: Ven 27 Oct 2017 - 18:40    Sujet du message: Problème de de légende Répondre en citant

Tous les attributs projet accessibles par l'utilisateur sont "alphanumériques".
Il faut que tu "convertisses" ta valeur "chaîne" en numérique avant de faire ton calcul. Essaie ça : " CNUM ( ta_valeur ) " ou " VALUE ( ta_valeur , 1 ) "
Je pense que le séparateur des décimales doit être le point (".") et non la virgule.


Revenir en haut
Visiter le site web du posteur
dead
Membre

Hors ligne

Inscrit le: 20 Déc 2011
Messages: 1 631
Localisation: 2 chèvres
Masculin

MessagePosté le: Lun 30 Oct 2017 - 15:11    Sujet du message: Problème de de légende Répondre en citant

j’essaierai ça merci BCO !! t'es une vrai mère pour moi Okay


c'est pas faux !
Revenir en haut
Contenu Sponsorisé






MessagePosté le: Aujourd’hui à 20:40    Sujet du message: Problème de de légende

Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Allplan Forum Index du Forum -> ALLPLAN -> DIVERS Toutes les heures sont au format GMT + 2 Heures
Aller à la page: 1, 2  >
Page 1 sur 2

 
Sauter vers:  

Index | creer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
darkages Template © larme d'ange
Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com