Allplan Forum Index du Forum
Allplan Forum Index du Forum FAQ Rechercher S’enregistrer Connexion

SMARTPART ET LAYER ASSIGNE - Allplan 2014

 
Poster un nouveau sujet   Répondre au sujet    Allplan Forum Index du Forum -> ALLPLAN -> ARCHITECTURE
Sujet précédent :: Sujet suivant  
Auteur Message
AnneSolenn
Membre

Hors ligne

Inscrit le: 13 Mar 2014
Messages: 7
Localisation: Rennes
Féminin

MessagePosté le: Jeu 13 Mar 2014 - 17:52    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014 Répondre en citant

Bonjour,

Je cherche à monter une bibliothèque d'éléments SmartPart, j'ai créé un paramètre de layer appelé la_oss qui apparait comme il faut dans la fenêtre de propriétés de la smartpart, j'ai tenté dans le Script 3D un LAYER la_oss, COLOR BY_LAYER, PEN BY_LAYER et STROKE BY_LAYER, également avec Set devant mais rien n'y fait : la smartpart prend le layer activé dans la fenêtre lors de la pause...

Quelqu'un pourrait-il m'indiquer comment corriger?

Merci
Revenir en haut
Publicité






MessagePosté le: Jeu 13 Mar 2014 - 17:52    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
BRINON
Membre

Hors ligne

Inscrit le: 11 Déc 2012
Messages: 860
Localisation: ALLANCHE 15
Masculin

MessagePosté le: Jeu 13 Mar 2014 - 21:25    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014 Répondre en citant

je ne pige pas complètement ta question, mais as tu pensée à cocher les 2 cases d'assignation




C'est en se plantant qu'on devient cultivé ...
Les membres suivants remercient BRINON pour ce message :
AnneSolenn (18/03/14)
Revenir en haut
Graphitus
Membre

Hors ligne

Inscrit le: 16 Jan 2012
Messages: 520
Localisation: VDMarnie
Masculin

MessagePosté le: Ven 14 Mar 2014 - 10:58    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014 Répondre en citant

J'ai aussi ce problème avec le module modéliser (porte ou fenêtre) d'un SmartPart,
il prend par défaut le layer en cour même si il est enregistré depuis sa création sur le bon layer.
Dans ce cas je passe par " Modifier les propriétés de format d'un élément " et je lui attribut le bon layer.

Peut-être un besoin de mise à jour ou bien quelqu'un a-il une meilleure solution?


Dernière édition par Graphitus le Dim 16 Mar 2014 - 12:42; édité 1 fois
Revenir en haut
BRINON
Membre

Hors ligne

Inscrit le: 11 Déc 2012
Messages: 860
Localisation: ALLANCHE 15
Masculin

MessagePosté le: Ven 14 Mar 2014 - 18:14    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014 Répondre en citant

Est ce que ce réglage n'influerait pas votre assignation des layers



parce qu si tu regarde bien, les smartparts des portes et fenêtres (en tout cas ceux de l'assistant DataExpress sont composés de macros ...


C'est en se plantant qu'on devient cultivé ...
Les membres suivants remercient BRINON pour ce message :
AnneSolenn (18/03/14)
Revenir en haut
Graphitus
Membre

Hors ligne

Inscrit le: 16 Jan 2012
Messages: 520
Localisation: VDMarnie
Masculin

MessagePosté le: Sam 15 Mar 2014 - 08:03    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014 Répondre en citant

Merci Brinon, ce réglage fonctionne effectivement bien avec les macro et les symboles, mais pas avec les SmartPart non convertis.
La V2014-1 arrive bientôt, on verra bien. Okay


Dernière édition par Graphitus le Dim 16 Mar 2014 - 12:41; édité 1 fois
Revenir en haut
bco
Modérateur

Hors ligne

Inscrit le: 23 Mar 2012
Messages: 3 928
Localisation: Toulouse
Masculin

MessagePosté le: Dim 16 Mar 2014 - 11:41    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014 Répondre en citant

AnneSolenn a écrit:
Bonjour,

Je cherche à monter une bibliothèque d'éléments SmartPart, j'ai créé un paramètre de layer appelé la_oss qui apparait comme il faut dans la fenêtre de propriétés de la smartpart, j'ai tenté dans le Script 3D un LAYER la_oss, COLOR BY_LAYER, PEN BY_LAYER et STROKE BY_LAYER, également avec Set devant mais rien n'y fait : la smartpart prend le layer activé dans la fenêtre lors de la pause...

Quelqu'un pourrait-il m'indiquer comment corriger?

Merci

Le comportement DU SmartPart (c'est un nom masculin au passage...) est tout à fait normal. La propriété de layer est une propriété de dépendance. Cela implique que seuls les éléments ajoutés après l'instruction LAYER seront affectés. Le SmartPart restera globalement affecté au layer défini lors de la pose ou après modification avec la fonction "Modifier les propriétés de format d'un élément".
Cette fonction LAYER ne peut pas changer le layer global du SmartPart. Par contre, l’intérêt est de pouvoir, au sein d'un même objet, définir certains éléments sur un layer et certains sur un autre, tout comme on peut avoir différentes couleurs, différentes épaisseurs de trait ou différents types de trait.
Smile


Les membres suivants remercient bco pour ce message :
AnneSolenn (18/03/14)
Revenir en haut
Visiter le site web du posteur
Graphitus
Membre

Hors ligne

Inscrit le: 16 Jan 2012
Messages: 520
Localisation: VDMarnie
Masculin

MessagePosté le: Dim 16 Mar 2014 - 12:45    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014 Répondre en citant

Le comportement DU SmartPart (c'est un nom masculin au passage...)

Ok, ok ... pour moi c'est corrigé Smile
Revenir en haut
bco
Modérateur

Hors ligne

Inscrit le: 23 Mar 2012
Messages: 3 928
Localisation: Toulouse
Masculin

MessagePosté le: Dim 16 Mar 2014 - 15:22    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014 Répondre en citant




Revenir en haut
Visiter le site web du posteur
AnneSolenn
Membre

Hors ligne

Inscrit le: 13 Mar 2014
Messages: 7
Localisation: Rennes
Féminin

MessagePosté le: Mar 18 Mar 2014 - 12:40    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014 Répondre en citant

Merci à tous pour vos conseils, j'ai maintenant bien compris la subtilité de l'attribution des layers dans les smartparts !
Revenir en haut
AnneSolenn
Membre

Hors ligne

Inscrit le: 13 Mar 2014
Messages: 7
Localisation: Rennes
Féminin

MessagePosté le: Mar 18 Mar 2014 - 12:47    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014 Répondre en citant

J'aurai bien aimé le mettre en résolu mais je n'ai pas de bouton "éditer" à côté de mon premier message...
Revenir en haut
BRINON
Membre

Hors ligne

Inscrit le: 11 Déc 2012
Messages: 860
Localisation: ALLANCHE 15
Masculin

MessagePosté le: Mar 18 Mar 2014 - 15:13    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014 Répondre en citant

AnneSolenn a écrit:

J'aurai bien aimé le mettre en résolu mais je n'ai pas de bouton "éditer" à côté de mon premier message...
c'est bon, je l'ai fait pour toi
@+


C'est en se plantant qu'on devient cultivé ...
Revenir en haut
Contenu Sponsorisé






MessagePosté le: Aujourd’hui à 11:20    Sujet du message: SMARTPART ET LAYER ASSIGNE - Allplan 2014

Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    Allplan Forum Index du Forum -> ALLPLAN -> ARCHITECTURE Toutes les heures sont au format GMT + 1 Heure
Page 1 sur 1

 
Sauter vers:  

Index | creer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
darkages Template © larme d'ange
Powered by phpBB © 2001, 2005 phpBB Group
Traduction par : phpBB-fr.com